MENU

宝塔面板composer配置

2021 年 02 月 27 日 • 阅读: 271 • 主机管理面板

我们初次使用宝塔面板的Composer功能的时候往往会遇到这种情况:

情况一、

1.jpg

以上情况表示你需要更新下composer,命令行输入:

composer selfupdate

情况二、

2.jpg

以上情况,黄色警告部分需要打开php禁用的函数 proc_open,注意,这里的PHP指的你当前PHP命令行版本,也就是在宝塔面板->网站,页面内。

3.jpg

我当前是7.4版本,因此我需要设置php的函数,位置在于,面板->软件商店->当前PHP设置->禁用函数:

4.jpg

需要在右侧列表中需要删除以下几个函数即可:

proc_open,putenv, passthru(可选)
最后编辑于: 2021 年 03 月 07 日
返回文章列表 文章二维码
本页链接的二维码
打赏二维码